Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Info inside] Psuedo-Recording; Stutter Bug Fix

06-20-2013, 07:32 PM
Post: #11
RE: [Info inside] Psuedo-Recording; Stutter Bug Fix
(06-20-2013 04:13 PM)Frost Wrote:  Have you tried disabling some CPU cores for those games?
I have noticed that some games did what you are describing on my quad-core, disabling the last two cores fixed the issue.

Makes no difference.

Heck, with Fallout 3/NV, the game hard-crashes when I change the affinity like that.
Find all posts by this user
Quote this message in a reply
06-27-2013, 09:01 AM (This post was last modified: 06-27-2013 09:04 AM by Sec.)
Post: #12
RE: [Info inside] Psuedo-Recording; Stutter Bug Fix
It sounds to me this is a CPU-Power management problem rather than a graphics card related issue. The way described probably keeps the CPU from saving power and making it more responsive.

To be able to access all CPU power management features in: Control Panel -> Power Options -> Currently used Power Profile -> Change Plan Settings -> Change Advanced Power Settings -> Processor Power Management.
You can use the .reg file in the dropbox link below (this file is for Win7) or use notepad to open it to see what values are changed. (attributes=0 makes them visible, and Valuemax makes it possible to input higher values)
https://www.dropbox.com/s/hi9eyke0j3objk...reg?v=0rc-

This doesnt change the powersettings, just makes them available to be changed.

Couple things to keep in mind to reduce stutter.

1st: 1 setting states the processor will be upped in speed (unlock/unpark a core) when the CPUload is about 30%, which is at about 60% of CPUload on 1 core when you have a Double core.
I for example have a triple core processor, so you see the problem, right now i have set it to 60% of 1 core which is 60%x33%= around 20% of CPU.

2nd: some timeouts are set too high, 1 timeout to up the CPU performance is set to 15 milliseconds, which means if the CPU has been to busy it waits for 15 milliseconds before it ups the power.
A monitor @60hz, means 16 milliseconds per frame, you can probably see that the cpu will never be able to finish the frame on time this way.
I have succesfully set the power-increase-timeouts to 1 millisecond without any negative sideaffects.

3rd: Just disabling CPU Core Parking (as some of you have probably already tried) doesnt work and doesnt get rid of microstutter.
The CPU has more than 1 powermanagement feature, if core-parking is disabled, it will gain some performance which means task is finished more quickly which means it will more often just use more Idling, Throttling down, and Lower Powerstates, which are the other three techniques for reducing power usage.
All of them need to be set, to get rid of microstutter as much as possible.
I personally for example saw a big difference after i changed the settings for CPU Idling & Throttling.

My settings in the file below are for a triple core. (open with notepad)
https://www.dropbox.com/s/kqrpj2zu7qcr85...ttings.txt
They`re not perfect but imho a large improvement, and i would like to hear some idea`s on how to improve them further.
Find all posts by this user
Quote this message in a reply
06-27-2013, 05:56 PM
Post: #13
RE: [Info inside] Psuedo-Recording; Stutter Bug Fix
That makes a lot of sense, Sec. BTW, I have core parking disabled since forever.

RadeonPro Users Guide - RadeonPro Features
Find all posts by this user
Quote this message in a reply
07-03-2013, 09:49 AM (This post was last modified: 07-03-2013 09:51 AM by MajinCry.)
Post: #14
RE: [Info inside] Psuedo-Recording; Stutter Bug Fix
Those changes you recommended did absolutely nothing. The microstutter still occurs. As I said, the only fix appears to be to have RadeonPro recording whilst playing.
Find all posts by this user
Quote this message in a reply
07-04-2013, 10:12 PM
Post: #15
RE: [Info inside] Psuedo-Recording; Stutter Bug Fix
Just tried your recording technique and for me it made a difference for 1 game.
Afterwards i set the game profile to use Dynamic Framerate at 60hz and that was exactly the difference.
So i think that is what you are looking for as John has already stated.

I have also found that if you add Aliasses at the Triggers-tab they dont always take.

With Fallout3 you have two executables, Fallout3.exe and FalloutLauncher.exe
Maybe try to make a separate profile (with the same settings, and with DFC turned on) for each ".exe"-file and see what happens.
Another thing, its a Windows Live game, it might be Windows Live has stolen focus which makes the profile not properly apply and use the global profile instead maybe, i have had this issue with the Logitech profiler in combination with GFWL sometimes.
Find all posts by this user
Quote this message in a reply
07-08-2013, 10:01 AM
Post: #16
RE: [Info inside] Psuedo-Recording; Stutter Bug Fix
(07-04-2013 10:12 PM)Sec Wrote:  -snip-

As I said, DFC didn't work. And it's not just the Fallout games that have this issue; another example would be Mount And Blade: Warband. Guess what? The recording removes the strange microstutter.

It's not in ever game, and not everyone has it for the games that do. But this "fix" works, which is extremely odd.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)