Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Triplebuffering turned off in user.cfg but still on in Radeonpro OSD

07-15-2013, 08:06 AM
Post: #1
Triplebuffering turned off in user.cfg but still on in Radeonpro OSD
Hi.
(First: Thank you for an awesome software - Radeonpro is what CCC should have been :-) )

Question:

Apperantly Triplebuffering is turned on as standard in Bf3..... but a user.cfg with:

RenderDevice.TripleBufferingEnable 0

..... should turn it off when placed in the BF3 folder.

I made this user.cfg and placed it in the right folder BUT in the in game Radeonpro OSD there is a "green dot" in Triplebuffering........ and I cannot turn it off/on like I can with FXAA and SMAA in the osd ingame......

(Tripplebuffering is not ticked off in Radeonpro)


1) When OSD reports Tripplebuffering as "green" is it on ? and just disregarding the user-cfg.

or

2) Is it a "false green dot"?

or is something not working right?

PS: win 7 64 bit, HD7950 Crossfire setup, i5 - 2500k
Find all posts by this user
Quote this message in a reply
07-15-2013, 07:05 PM
Post: #2
RE: Triplebuffering turned off in user.cfg but still on in Radeonpro OSD
Do you have DVC enabled in RadeonPro?

RadeonPro Users Guide - RadeonPro Features
Find all posts by this user
Quote this message in a reply
07-15-2013, 08:28 PM
Post: #3
RE: Triplebuffering turned off in user.cfg but still on in Radeonpro OSD
(07-15-2013 07:05 PM)John Wrote:  Do you have DVC enabled in RadeonPro?

No.... In TWEAKS tab I have set V-sync to driver default (If thats what you mean) and only set DFC to 85 fps and nothing else
Find all posts by this user
Quote this message in a reply
07-15-2013, 08:56 PM (This post was last modified: 07-15-2013 08:57 PM by John.)
Post: #4
RE: Triplebuffering turned off in user.cfg but still on in Radeonpro OSD
Ok, thanks.

Just tried an user.cfg with RenderDevice.TripleBufferingEnable 0 and the game is still using 3 buffers from what I can see in debug logs.

BufferCount=3, Width=1920, Height=1200, NewFormat=28, SwapChainFlags=2

I know the file user.cfg is in effect because I also have GameTime.MaxVariableFPS 35 and FPS locks to 35 FPS.

Removed the user.cfg and tried again, the result is the same

BufferCount=3, Width=1920, Height=1200, NewFormat=28, SwapChainFlags=2

So it seems the game is skipping/ignoring the command RenderDevice.TripleBufferingEnable.

RadeonPro Users Guide - RadeonPro Features
Find all posts by this user
Quote this message in a reply
07-16-2013, 06:21 AM
Post: #5
RE: Triplebuffering turned off in user.cfg but still on in Radeonpro OSD
(07-15-2013 08:56 PM)John Wrote:  Ok, thanks.

Just tried an user.cfg with RenderDevice.TripleBufferingEnable 0 and the game is still using 3 buffers from what I can see in debug logs.

BufferCount=3, Width=1920, Height=1200, NewFormat=28, SwapChainFlags=2

I know the file user.cfg is in effect because I also have GameTime.MaxVariableFPS 35 and FPS locks to 35 FPS.

Removed the user.cfg and tried again, the result is the same

BufferCount=3, Width=1920, Height=1200, NewFormat=28, SwapChainFlags=2

So it seems the game is skipping/ignoring the command RenderDevice.TripleBufferingEnable.

Thank you for your help on this.

.... your 100% right .... it seems that its not possible to force triplebuffering off in BF3 eventhough the user.cfg solution is all over google.....(sometimes I forget tha google is not always correct :-) )

I tried:

1) The same as you and framelimit is working fine in user.cfg but not triplebuffering.

and

2) In Bf3 I went into the "console (~)" menu and tried to change "RenderDevice.TripleBufferingEnable 1" to "RenderDevice.TripleBufferingEnable 0".........but it came up "false"... so it will only accept "1" and not "0".

I just like to be "in control" of my software - but this one has beaten me...

PS: Again: Thank you for the awesome Radeonpro application!
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)