Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Turning RadeonPro on kills my FPS

07-06-2013, 09:04 AM
Post: #1
Turning RadeonPro on kills my FPS
Hi,
just yesterday I installed Windows 8 x64, and with nothing but standard ATI drivers I fired up league of legends, put everything on high, disabled shadows, and got a nice steady ~100fps.

Then (as I always do), I downloaded the latest RadeonPro, installed and started it, and turned everything off or left it at "use application settings" and just set the dynamic framerate control to 60fps.

After loading a LoL game, I was getting 52-53fps, and despite that not usually being that bad, the game just felt terribly laggy, especially when it comes to panning the screen around.

Went back out, disabled RadeonPro, and actually completely closed it after that, but my LoL is just stuck at terrible performance and 52-53fps.

Only after restarting my PC does my game go back to 100fps and great performance, but simply loading radeonpro at any point will ruin it until I restart the PC.

What gives? I've been playing around with the options for hours now and I can't seem to achieve anything whatsoever.

I'm playing on a Lenovo Ideapad Y560p with a HD6570m inside, and the latest official ATI drivers.
I've been using RadeonPro for ages and it's always been my go-to app, but I'm really bummed now and I don't know what else to try.

Please help!
Find all posts by this user
Quote this message in a reply
07-06-2013, 09:42 PM
Post: #2
RE: Turning RadeonPro on kills my FPS
I really don't know what's going down there.

BTW, mobile chips are not supported, most people have issues using RadeonPro with mobile chips like yours.

RadeonPro Users Guide - RadeonPro Features
Find all posts by this user
Quote this message in a reply
07-10-2013, 03:45 PM (This post was last modified: 07-10-2013 03:46 PM by MajinCry.)
Post: #3
RE: Turning RadeonPro on kills my FPS
Edit: Bah. Stupid me for speed-reading.

Give us screenshots of your RadeonPro settings.

Also, make sure the Catalyst AI setting is on "Advanced".
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)