Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Some bugs and glitches

04-14-2013, 06:57 PM
Post: #11
RE: Some bugs and glitches
Yes, as DinoThrasher posted the problem relies on input control that deals with SMAA and SweetFX values. I trying to isolate why the control is causing those CPU spikes because (unfortunately) I don't have here.

RadeonPro Users Guide - RadeonPro Features
Find all posts by this user
Quote this message in a reply
04-14-2013, 07:19 PM
Post: #12
RE: Some bugs and glitches
Again, I'd like to point out that it's the incremental arrows specifically that appear to be causing the issue. Some more comparison shots are included. I've marked the relevant areas of the pic with a red box:

Picture 1: The option "Cartoon" under "SweetFX" has 1 set of incremental arrows and the flickering problem occurs:
[Image: gXaZT8f.png]


Picture 2: The option "Curves" under "SweetFX" has 2 drop boxes and 1 manual entry field and the flickering problem DOES NOT occur:
[Image: 9C7T0LO.png]


I also went back and checked. All versions of RadeonPro released after 30/Mar/2013 have this issue. Earlier versions of 1.1.0.6, obviously, don't have this issue.

Additionally, before upgrading to the most recent release (13/Apr/2013), I was using an early preview of 1.1.1.0 from the Guru3D forums post that did not have these tables for SMAA or the SweetFX features implemented yet and the flickering problem was non-existent.

At this point I'm not sure I'm actually giving any new or relevant information, but I figure anything I haven't said in a previous post that MAY be relevant is worth mentioning.
Find all posts by this user
Quote this message in a reply
04-14-2013, 07:49 PM
Post: #13
RE: Some bugs and glitches
Yup, I understood that input control is causing it. I just can't replicate the issue here, making it harder to figure out why it is causing those spikes in CPU usage.

RadeonPro Users Guide - RadeonPro Features
Find all posts by this user
Quote this message in a reply
04-16-2013, 04:47 AM
Post: #14
RE: Some bugs and glitches
First I also have this bug(I believe I reported it in the Questions section sometime back). John couldn't recreate it then either, I just thought it was only me so it wasn't a big deal.

Anywho Specs.

AMD Phenom II X6 1090T, 3712 Mhz (Overclocked)
Microsoft Windows 7 Professional (x64)
6.1.7601 Service Pack 1 Build 7601
12 GB DDR3 RAM
AMD Radeon HD 7970 GHZ Edition 3 GB VRAM
Crosshair III Formula Motherboard
Catalyst Version 13.3

@ DinoThrasher and Murphfix
Here is a list of my processes. Please look through it and determine if we have any processes in common. This way we can determine if a program might be interfering with Radeonpro.

@ John
One more thing John. If you want I'm up to doing a Join.me desktop share (or whatever program would work) if you think you could determine the cause by testing things on my computer.

You guys need anything else please ask.
Find all posts by this user
Quote this message in a reply
04-16-2013, 05:13 AM
Post: #15
RE: Some bugs and glitches
Hmm....

Going through that process list, the only processes that jumped out at me were the Punkbuster and Razer related processes. I tried disabling these processes and still got the flickering.
It's 1am where I am here, so I don't really have the time to generate and upload a processes list for you to look at but I promise I'll figure it out tomorrow and upload it for you to view and compare on your own.

I also, out of curiosity, tried disabling the explorer.exe process on the off chance there was an issue there, but the flickering and CPU spikes persisted. Didn't think it would fix the problem, but I figured why not try anything and everything.
Find all posts by this user
Quote this message in a reply
04-16-2013, 09:31 AM
Post: #16
RE: Some bugs and glitches
Disabling 64-bit monitoring (just click at 32/64-bit at bottom/right corner of RP window) so it shows 32-bit does not help?

Anyway, I guess that bug won't be fixed because since last weekend I already started working on RP 2.0 which will have a totally different user interface, so that flickering/high cpu usage bug shouldn't happen anymore.

RadeonPro Users Guide - RadeonPro Features
Find all posts by this user
Quote this message in a reply
04-16-2013, 05:35 PM
Post: #17
Some bugs and glitches
Great what is the eta for 2.0?
Find all posts by this user
Quote this message in a reply
04-16-2013, 06:45 PM
Post: #18
RE: Some bugs and glitches
@John
Nope, that didn't fix the problem.

@Aether
In case you want to keep looking, here's that processes list I promised.
Find all posts by this user
Quote this message in a reply
04-16-2013, 10:48 PM
Post: #19
RE: Some bugs and glitches
(04-16-2013 05:35 PM)ToniSirReal Wrote:  Great what is the eta for 2.0?

No ETA...

(04-16-2013 06:45 PM)DinoThrasher Wrote:  @John
Nope, that didn't fix the problem.

Ok, thanks.

RadeonPro Users Guide - RadeonPro Features
Find all posts by this user
Quote this message in a reply
04-17-2013, 03:50 AM
Post: #20
RE: Some bugs and glitches
Thanks DinoThrasher, I've got the results of the process comparison here. I have determined so far the there are no processes that are interfering with RadeonPro. Disabling any (baring the windows processes as I didn't attempt to disable and check them) did nothing to Radeonpro and the bug persisted.

Upon closer observation of Radeonpro it appears that there is a buffer overflow when browsing SweetFX settings. One other thing of note is that radeonpro consistently attempts to modify a registry Key at "HKLM\SOFTWARE\MICROSOFT\Windows\CurrentVersion\Policies\Explorer\TurnOffSPIAnima​tions" and fails citing NAME_NOT_FOUND.

Otherwise everything is amazing. It's nice to hear that 2.0 is being worked on.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)