Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Black Screen with Cursor in Final Fantasy XIV - A Realm Reborn

08-24-2013, 08:30 AM
Post: #1
Black Screen with Cursor in Final Fantasy XIV - A Realm Reborn
First off, thanks for this awesome software, I just kicked a donation over your way to show my thanks Smile

Anyway, I noticed today with the early access launch of FFXIV ARR that if you try to use RadeonPro to do ANYTHING with this game that it ends up just having a black screen and cursor. It's currently a DX9 game, but will be updated to be DX11 in the coming months.

Here are the steps I went through to figure this out:

First I just enabled SweetFX and set it how I would want it for the game.

Second I made sure the CrossfireX Tweaks were not on and that the slider was set to Use Driver Default.

I then applied the profile, and launched the game through radeonpro.

The game launcher popped up, I logged in, and the main game client started. Upon starting it just has the black screen and the cursor. Nothing you can do about it.

I tried turning off all of the SweetFX stuff and then launched it to see if it could even be launched with the stock radeonpro global settings, and it still had the black screen and cursor.

Hoping you can get this fixed because I love being able to use radeonpro for tweaks and SweetFX, and I look forward to being able to with this game soon too.

Thank you!
Find all posts by this user
Quote this message in a reply
08-24-2013, 09:14 PM
Post: #2
RE: Black Screen with Cursor in Final Fantasy XIV - A Realm Reborn
Is that game a free to play one or does it have a demo version so I can try it out?

RadeonPro Users Guide - RadeonPro Features
Find all posts by this user
Quote this message in a reply
08-24-2013, 09:51 PM
Post: #3
RE: Black Screen with Cursor in Final Fantasy XIV - A Realm Reborn
it's not free nor is there a demo, there's a benchmark (i don't know if that helps you though) which is here http://na.finalfantasyxiv.com/benchmark/
Find all posts by this user
Quote this message in a reply
08-25-2013, 01:43 PM
Post: #4
RE: Black Screen with Cursor in Final Fantasy XIV - A Realm Reborn
Ok, thanks for the link. Let me try it and see what is happening, will keep you posted.

RadeonPro Users Guide - RadeonPro Features
Find all posts by this user
Quote this message in a reply
08-25-2013, 06:19 PM
Post: #5
RE: Black Screen with Cursor in Final Fantasy XIV - A Realm Reborn
The benchmark runs fine, can you try it too?

RadeonPro Users Guide - RadeonPro Features
Find all posts by this user
Quote this message in a reply
08-26-2013, 03:40 AM
Post: #6
RE: Black Screen with Cursor in Final Fantasy XIV - A Realm Reborn
I have some info on this. FFXIV crashes on launch with radeonpro running, But only if it is running in windowed or windowed borderless modes. If launched in fullscreen mode radeonpro behaves as usual with the exception of that SweetFX and SMAA don't seem to work at all. I've also tested this in the benchmark and it behaves the same way.
Find all posts by this user
Quote this message in a reply
09-02-2013, 10:25 AM
Post: #7
RE: Black Screen with Cursor in Final Fantasy XIV - A Realm Reborn
Same probleme here on official game , radeon pro black screen when i'm loging the game , on fullscreen , windowed , windowed borderless modes all mod .
I have ati amd 13.8 beta 2 driver with 7950 OC Vapor-X
Find all posts by this user
Quote this message in a reply
09-02-2013, 10:58 AM (This post was last modified: 09-02-2013 11:00 AM by paradoxical.)
Post: #8
RE: Black Screen with Cursor in Final Fantasy XIV - A Realm Reborn
Hey! Same deal here. The benchmark does run fine, no issue there, but the retail game will randomly not run at all.

With RadeonPro running, FFXIV sometimes will not load. It gets to a black screen before the opening trailers, and the mouse cursor does shift to the in-game cartoony one, but the scene stays black, and no music is playing/the FPS counter isn't present, so nothing is happening. This only happens sometimes, though - sometimes the game loads fine, with RadeonPro settings in tact. I'd say about 1/3 of the attempts I make to launch the game with RadeonPro will get beyond the black screen and run just fine. However, without RadeonPro running, the game will launch regularly 100% of the time. Windowed/full screen makes no difference.

The game does launch through a launcher, but the game will not even start the launcher when that setting is in place.

I'm using 13.8 beta 2 (although this was also true in beta 1), on 7870 crossfire. Let me know if there's anything I can do to assist, and thanks for an amazing piece of software =)
Find all posts by this user
Quote this message in a reply
09-03-2013, 11:58 AM
Post: #9
Re: Black Screen with Cursor in Final Fantasy XIV - A Realm Reborn
I should add that I also run the 13.8 beta 2 frame pacing drivers.
Find all posts by this user
Quote this message in a reply
09-03-2013, 03:44 PM
Post: #10
RE: Black Screen with Cursor in Final Fantasy XIV - A Realm Reborn
I have been getting this black screen ever since I installed RadeonPRO. It's almost as if it somehow made the game permanently take forever to load up. I even tried un-installing RadeonPRO and it still takes a good 30 seconds to get past the black screen. It was never like this before installing RadeonPRO. I noticed if you let the game wait for about 30 seconds it will sometimes start up and apply my settings, but otherwise it still has a large chance of crashing depending on what settings you have.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)